test_coverage 0.2.1

  • README.md
  • Installing
  • Versions
  • 35

test_coverage Build Status

A simple command-line tool to collect test coverage information from Dart VM tests. It is useful if you need to generate coverage reports locally during development.

Usage #

Add dev dependency to your pubspec.yaml:

  test_coverage: ^0.1.0

Run pub get to install. Then, in the root of your project run:

pub run test_coverage

Result is saved in coverage/coverage.lcov. If you have lcov tool installed on your system (for Mac it's brew install lcov) you can generate coverage reports using genhtml command:

genhtml -o coverage coverage/coverage.lcov
# Open in the default browser (mac):
open coverage/index.html

Integrations #

Resulting coverage/coverage.lcov file is ready to be consumed by Codecov command-line tool, so no extra step is needed.

This library was not tested with coveralls yet.

Known limitations #

  • This library was created to run Dart VM tests. It has not been tested and likely won't work for Dart code targeting web platform (compiled to JavaScript). There is no need to use this tool for Flutter as it allows collecting coverage information with flutter test --coverage.

How it works #

The tool performs following steps:

1. Generates test/.test_coverage.dart file which is essentially a "test all" script.

It is recommended to add this file to your .gitignore.

Below is an example of test/.test_coverage.dart:

// Auto-generated by test_coverage. Do not edit by hand.
// Consider adding this file to your .gitignore.

import 'some_test.dart' as some_test;
import 'nested/other_test.dart' as other_test;
import 'some_other_test.dart' as some_other_test;
void main() {

2. Runs the tests #

Following command is used to run the tests:

dart --pause-isolates-on-exit --enable_asserts --enable-vm-service \

3. Collects and formats coverage information #

When test execution is completed the tool uses functionality of the coverage package to collect and format coverage report.

Feel free to file feature requests and bug reports at the issue tracker.

0.2.1 #

  • Generate coverage badge in coverage/badge.svg.

0.2.0 #

  • Moved generated reports to coverage/ subfolder.
  • Added tests.
  • Updated usage instructions to recommend local dev_dependencies and pub run test_coverage instead of global installation.

0.1.1 #

  • Make paths in lcov file relative to the project root.

0.1.0 #

  • Initial version

Use this package as an executable

1. Install it

You can install the package from the command line:

$ pub global activate test_coverage

2. Use it

The package has the following executables:

$ test_coverage

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  test_coverage: ^0.2.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:test_coverage/test_coverage.dart';
Version Uploaded Documentation Archive
0.2.3 Jul 26, 2018 Go to the documentation of test_coverage 0.2.3 Download test_coverage 0.2.3 archive
0.2.2 Jul 10, 2018 Go to the documentation of test_coverage 0.2.2 Download test_coverage 0.2.2 archive
0.2.1 Jul 10, 2018 Go to the documentation of test_coverage 0.2.1 Download test_coverage 0.2.1 archive
0.2.0 Jul 9, 2018 Go to the documentation of test_coverage 0.2.0 Download test_coverage 0.2.0 archive
0.1.1 Jun 29, 2018 Go to the documentation of test_coverage 0.1.1 Download test_coverage 0.1.1 archive
0.1.0 Jun 29, 2018 Go to the documentation of test_coverage 0.1.0 Download test_coverage 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.66.0 <2.0.0