tempo_test 0.0.9

  • Readme
  • Changelog
  • Installing
  • 42

tempo_test #

A new flutter plugin project.

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.0.1 #

  • TODO: Describe initial release.

0.0.2 #

  • TODO: Describe initial release.
  • ADD APPVERSION METHOD

0.0.3 #

  • FIX BUG

0.0.4 #

  • add mothod

0.0.5 #

  • route native method

0.0.6 #

  • route native method1

0.0.7 #

  • modify subspec

0.0.8 #

  • add close page method

0.0.9 #

  • add play system sound method

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  tempo_test: ^0.0.9

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:tempo_test/tempo_test.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
42
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:tempo_test/tempo_test.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:tempo_test/tempo_test.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:tempo_test/tempo_test.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:tempo_test/tempo_test.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [tempo_test] that is in a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

8 out of 8 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/tempo_test.dart.

Run flutter format to format lib/tempo_test.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and tempo_test.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test