tap_network_kit 1.0.0

  • Readme
  • Changelog
  • Installing
  • 56

tap_network_kit #

A new Flutter package project.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[1.0.0] - 27-04-2020 #

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  tap_network_kit: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:tap_network_kit/tap_network_kit.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
33
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
56
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:tap_network_kit/tap_network_kit.dart that imports:
  • package:tap_network_kit/src/retrofit/api_service.dart that imports:
  • package:tap_network_kit/src/retrofit/retrofit_helper.dart that imports:
  • package:tap_network_kit/src/interceptors/request_interceptor.dart that imports:
  • package:connectivity/connectivity.dart that declares support for platforms: android, ios, macos, web

Package does not support Flutter platform windows

Because:

  • package:tap_network_kit/tap_network_kit.dart that imports:
  • package:tap_network_kit/src/retrofit/api_service.dart that imports:
  • package:tap_network_kit/src/retrofit/retrofit_helper.dart that imports:
  • package:tap_network_kit/src/interceptors/request_interceptor.dart that imports:
  • package:connectivity/connectivity.dart that declares support for platforms: android, ios, macos, web

Package not compatible with SDK dart

Because:

  • tap_network_kit that is a package requiring null.

Health suggestions

Fix lib/src/app_info/app_info.dart. (-1 points)

Analysis of lib/src/app_info/app_info.dart reported 2 hints:

line 11 col 17: The value of the field '_device' isn't used.

line 12 col 17: The value of the field '_deviceId' isn't used.

Fix lib/src/interceptors/request_interceptor.dart. (-1 points)

Analysis of lib/src/interceptors/request_interceptor.dart reported 2 hints:

line 2 col 8: Unused import: 'package:connectivity/connectivity.dart'.

line 5 col 8: Unused import: 'package:tap_network_kit/src/exceptions/mobile_connectivity_exception.dart'.

Format lib/src/constants/api_constants.dart.

Run flutter format to format lib/src/constants/api_constants.dart.

Fix additional 8 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/converter/tap_converter.dart (Run flutter format to format lib/src/converter/tap_converter.dart.)
  • lib/src/exceptions/exception_base.dart (Run flutter format to format lib/src/exceptions/exception_base.dart.)
  • lib/src/exceptions/request_exception.dart (Run flutter format to format lib/src/exceptions/request_exception.dart.)
  • lib/src/interceptors/response_interceptor.dart (Run flutter format to format lib/src/interceptors/response_interceptor.dart.)
  • lib/src/interface/response_model_interface.dart (Run flutter format to format lib/src/interface/response_model_interface.dart.)
  • lib/src/retrofit/api_service.dart (Run flutter format to format lib/src/retrofit/api_service.dart.)
  • lib/src/retrofit/retrofit_helper.dart (Run flutter format to format lib/src/retrofit/retrofit_helper.dart.)
  • lib/tap_network_kit.dart (Run flutter format to format lib/tap_network_kit.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (chopper, provider).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and tap_network_kit.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
chopper ^2.5.0 2.5.3 3.0.3
connectivity ^0.4.3+7 0.4.9
flutter 0.0.0
logging ^0.11.4 0.11.4
provider ^3.0.0+1 3.2.0 4.3.0
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
connectivity_for_web 0.3.0
connectivity_macos 0.1.0+3
connectivity_platform_interface 1.0.6
flutter_web_plugins 0.0.0
http 0.12.1
http_parser 3.1.4
js 0.6.2
meta 1.1.8 1.2.1
path 1.7.0
pedantic 1.9.0 1.9.1
plugin_platform_interface 1.0.2
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
build_runner ^1.0.0
chopper_generator ^2.0.0
flutter_test