sy_flutter_widgets 0.1.4

  • Readme
  • Changelog
  • Example
  • Installing
  • 87

Build Status

sy_flutter_widgets #

纯flutter Widget组件库,不依赖Native及其它第三方package。包括省市区选择器,Rate评分,Stepper步进器,照片墙,地址编辑,自带加载更多的ListView和GridView

__

#### 其它Flutter plugin

[0.1.4] - 2018-11-25

  • translate pubspec.yaml description

[0.1.3] - 2018-11-25

[0.1.2] - 2018-11-25

  • add circle progress bar widget
  • add wave progress bar widget
  • add colorful divider widget

[0.1.1] - 2019-10-28

  • 添加省市区选择器,地址编辑器,照片墙组件

[0.0.1] - 2019-10-17

  • Initial release

example/README.md

example #

demo

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sy_flutter_widgets: ^0.1.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sy_flutter_widgets/sy_flutter_widgets.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
74
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
87
Learn more about scoring.

We analyzed this package on Oct 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/src/address_edit.dart. (-1 points)

Analysis of lib/src/address_edit.dart reported 2 hints:

line 43 col 18: This function has a return type of 'String', but doesn't end with a return statement.

line 98 col 18: This function has a return type of 'String', but doesn't end with a return statement.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test