swipeable 1.0.1+1

  • README.md
  • Example
  • Installing
  • Versions
  • 68

swipeable #

BuildStatus Pub

A widget that emits events when swiped past a threshold


Usage #

see the /example directory

[1.0.1] - TODO: Add release date.

  • fix poor animation framerate
  • add tests


example #

A new Flutter project.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  swipeable: ^1.0.1+1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:swipeable/swipeable.dart';
Version Uploaded Documentation Archive
1.0.1+1 May 23, 2019 Go to the documentation of swipeable 1.0.1+1 Download swipeable 1.0.1+1 archive
1.0.1 May 23, 2019 Go to the documentation of swipeable 1.0.1 Download swipeable 1.0.1 archive
1.0.0+1 Oct 30, 2018 Go to the documentation of swipeable 1.0.0+1 Download swipeable 1.0.0+1 archive
1.0.0 Oct 30, 2018 Go to the documentation of swipeable 1.0.0 Download swipeable 1.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jun 26, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies