sushichain 0.0.2

  • Readme
  • Changelog
  • Installing
  • 39

SushiChain Crypto #

A Flutter plugin for iOS and Android providing the base crypto functions for the SushiChain blockchain platform.

Features #

  • generateKeyPair
  • generateNewWallet
  • generateWif
  • generateAddress
  • getWalletFromWif
  • getFullWalletFromWif
  • encryptWallet
  • decryptWallet

Installation #

Add the dependency to your pubspec.yaml

  sushichain: ^0.0.2

Example #

import 'package:dartz/dartz.dart';
import 'package:sushichain/network.dart';
import 'package:sushichain/wallet_factory.dart';

  // Do something with the basicWallet here


  • Initial release with core sushichain crypto


  • Refactor to use tiny types
  • Documented the code a bit

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  sushichain: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:sushichain/basic_wallet.dart';
import 'package:sushichain/encrypted_wallet.dart';
import 'package:sushichain/full_wallet.dart';
import 'package:sushichain/keypair.dart';
import 'package:sushichain/model.dart';
import 'package:sushichain/network.dart';
import 'package:sushichain/wallet_error.dart';
import 'package:sushichain/wallet_factory.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 14, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart


  • sushichain that is a package requiring null.

Health suggestions

Format lib/basic_wallet.dart.

Run flutter format to format lib/basic_wallet.dart.

Format lib/encrypted_wallet.dart.

Run flutter format to format lib/encrypted_wallet.dart.

Format lib/model.dart.

Run flutter format to format lib/model.dart.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/network.dart (Run flutter format to format lib/network.dart.)
  • lib/wallet_error.dart (Run flutter format to format lib/wallet_error.dart.)
  • lib/wallet_factory.dart (Run flutter format to format lib/wallet_factory.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (dartz).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and sushichain.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Package is getting outdated. (-6.30 points)

The package was last published 55 weeks ago.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
convert ^2.1.1 2.1.1
crypto ^2.0.6 2.1.5
dartz ^0.8.4 0.8.9 0.9.1
flutter 0.0.0
pointycastle ^1.0.1 1.0.2
quiver_hashcode ^2.0.0 2.0.0
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies