survey_js_core 0.0.2+1

Package for generating survey model from json. Usage:- After creating survey json,you have to pass it to the SurveyJsonParser

SurveyJsonParser surveyJsonParser =SurveyJsonParser();
surveyJsonParser.parseSurveyJson(json);

parseSurveyJson(json) method return the Survey object.
for validating your questions you have to pass your survey model and input data.
input data you have to pass in the below format.

 List<Map<String, dynamic>> data;

where in Map key will be your questionName and value could be anything.

SurveyChecker surveyChecker=SurveyChecker();
surveyChecker.completeSurvey(surveyModel, data);

completeSurvey(surveyModel,data) method will give error if any.

Note:-currently there are four question type supported.

  1. Text
  2. CheckBox
  3. Radiogroup
  4. Dropdown.

for more information visit https://surveyjs.io/.

[0.0.2+1] -24-july-2019

Package for generating survey model from json.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  survey_js_core: ^0.0.2+1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:survey_js_core/survey_js_core.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
17
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-0.78 points)

545 out of 549 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/model/base.dart. (-0.50 points)

Analysis of lib/model/base.dart reported 1 hint:

line 2 col 8: The value of the field '_isLoadingFromJson' isn't used.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and survey_js_core.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test