supports_color 0.1.1

  • README.md
  • Installing
  • Versions
  • 0

supports_color pub package Build Status

Detect whether the current terminal supports color.

This is a dart port of the npm supports-color package.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  supports_color: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:supports_color/supports_color.dart';
  
Version Uploaded Documentation Archive
0.1.1 Oct 17, 2014 Go to the documentation of supports_color 0.1.1 Download supports_color 0.1.1 archive
0.1.0 Oct 16, 2014 Go to the documentation of supports_color 0.1.0 Download supports_color 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
1
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.