super_widgets 1.0.0

Flutter Android iOS web

Make Flutter widgets' code shorter and richer by combining multiple widgets into a single widget but the single one will inherit almost properties of all original widgets.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  super_widgets: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:super_widgets/super_widgets.dart';
2
likes
110
pub points
43%
popularity

Publisher

fluttervn.com

Make Flutter widgets' code shorter and richer by combining multiple widgets into a single widget but the single one will inherit almost properties of all original widgets.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on super_widgets