subx 1.17.0 copy "subx: ^1.17.0" to clipboard
subx: ^1.17.0 copied to clipboard

RxDart Subscriptions management. Provide Apis to store and manage RxDart subscriptions and provide methods to unsubscribe them all.

1.17.0 #

  • FEAT: updated dependencies.

1.16.0 #

  • FEAT: update dependencies.
  • FEAT: update dependencies.
  • FEAT: update dependencies.
  • FEAT: update dependencies.
  • FEAT: update dependencies.
  • FEAT: update dependencies.
  • FEAT: minor improvements.
  • FEAT: update to dart 3 & flutter 3.10.0.
  • FEAT: update dependencies.
  • FEAT: minor improvements.
  • FEAT: add existing libraries.
  • FEAT: add subx package.

1.15.0 #

  • FEAT: update dependencies.

1.14.0 #

  • FEAT: update dependencies.
  • FEAT: update dependencies.
  • FEAT: update dependencies.
  • FEAT: update dependencies.
  • FEAT: update dependencies.
  • FEAT: minor improvements.
  • FEAT: update to dart 3 & flutter 3.10.0.
  • FEAT: update dependencies.
  • FEAT: minor improvements.
  • FEAT: add existing libraries.
  • FEAT: add subx package.

1.13.2 #

  • Bump "subx" to 1.13.2.

1.13.1 #

  • minor improvements

1.13.0 #

  • FEAT: update dependencies.
  • FEAT: update dependencies.
  • FEAT: update dependencies.
  • FEAT: update dependencies.
  • FEAT: update dependencies.
  • FEAT: minor improvements.
  • FEAT: update to dart 3 & flutter 3.10.0.
  • FEAT: update dependencies.
  • FEAT: minor improvements.
  • FEAT: add existing libraries.
  • FEAT: add subx package.

1.12.0 #

  • FEAT: update dependencies.
  • FEAT: update dependencies.
  • FEAT: update dependencies.
  • FEAT: update dependencies.
  • FEAT: update dependencies.
  • FEAT: minor improvements.
  • FEAT: update to dart 3 & flutter 3.10.0.
  • FEAT: update dependencies.
  • FEAT: minor improvements.
  • FEAT: add existing libraries.
  • FEAT: add subx package.

1.11.0 #

  • FEAT: update dependencies.

1.10.0 #

  • FEAT: update dependencies.

1.9.0 #

  • FEAT: update dependencies.

1.8.0 #

  • FEAT: update dependencies.

1.7.0 #

  • FEAT: update dependencies.

1.6.0 #

  • FEAT: minor improvements.

1.5.0 #

  • FEAT: update to dart 3 & flutter 3.10.0.

1.4.0 #

  • FEAT: update dependencies.

1.3.0 #

  • FEAT: minor improvements.
  • FEAT: add existing libraries.
  • FEAT: add subx package.

Changelog #

1.2.0 (2022-10-12) #

Enhancements #

  • Update dependencies.
  • Update sdk requirements.

1.1.0 (2022-02-08) #

Enhancements #

  • Update dependencies.
  • Update sdk requirements.

1.0.4 (2021-08-12) #

Enhancements #

  • Update dependencies.

1.0.3 (2021-06-28) #

Enhancements #

  • Update dependencies.

1.0.2 (2021-06-28) #

Enhancements #

  • Update dependencies.

1.0.1 (2021-05-16) #

Improvements #

  • Minor improvements.

1.0.0 (2021-03-24) #

  • First stable version.

0.7.0 (2021-03-05) #

Enhancements #

  • Supports sound null safety.

0.6.2 (2020-10-19) #

Enhancements #

  • Minor performance improvements.

0.6.1 (2020-10-10) #

Enhancements #

  • Minor improvements.

0.6.0 (2020-10-10) #

Features #

  • SubxList: Add the method addAll

Breaking Changes #

  • Requires dart 2.10.0

0.5.0 (2019-12-23) #

Breaking Changes #

  • Requires dart 2.6.0

0.4.0 (2019-09-24) #

Features #

  • SubxMap: Add the method pauseAll
  • SubxMap: Add the method resumeAll
  • SubxList: Add the method pauseAll
  • SubxList: Add the method resumeAll

0.3.0 (2019-05-29) #

Features #

  • First reviewed release
0
likes
160
pub points
18%
popularity

Publisher

unverified uploader

RxDart Subscriptions management. Provide Apis to store and manage RxDart subscriptions and provide methods to unsubscribe them all.

Repository (GitHub)
View/report issues

Documentation

API reference

License

ISC (LICENSE)

Dependencies

async, flutter

More

Packages that depend on subx