sub4dart 0.0.5

  • Readme
  • Changelog
  • Example
  • Installing
  • 53

A subsonic API wrapper written in Dart

Created from templates made available by Stagehand under a BSD-style license.

Usage #

A simple usage example:

import 'package:sub4dart/sub4dart.dart';

main() async {
  var subsonic = new SubSonic("https://music.example.com","John","Doe");
  await subsonic.getPing(); // Returns a response if successfully authenticated
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

0.0.5 #

  • added client.changeSettings

0.0.3 #

  • Fixed inheriting issue

0.0.2 #

  • Renamed SubSonic class to SubSonicClient
  • Created SubSonicAPI abstract class for managing endpoints
  • Created MockClient for testing

0.0.1 #

  • Initial version, created by Stagehand

example/sub4dart_example.dart

import 'package:sub4dart/src/models/subsonic_response.dart';
import 'package:sub4dart/sub4dart.dart';

main() async {
  var subsonic = new SubSonicClient("https://music.example.com", "John", "Doe");
  SubSonicResponse response = await subsonic.getPing();
  print(response.isOkay);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sub4dart: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sub4dart/sub4dart.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
10
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
53
Learn more about scoring.

We analyzed this package on Dec 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
crypto ^2.0.6 2.1.4
http ^0.12.0+1 0.12.0+2
password_hash ^2.0.0 2.0.0
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.12
convert 2.1.1
http_parser 3.1.3
meta 1.1.8
path 1.6.4
pedantic 1.9.0
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
test ^1.0.0