studentvueclient 0.0.4 copy "studentvueclient: ^0.0.4" to clipboard
studentvueclient: ^0.0.4 copied to clipboard

outdated

a client library for the student vue grade system

example/studentvueclient_example.dart

import 'package:studentvueclient/studentvueclient.dart';

void main() async {
  var client = StudentVueClient('my username', 'my password', 'my studentvue mobile app url', mock: true);
  print('loading data');
  var grades = await client.loadGradebook();
  print(grades.toString());
  var studentData = await client.loadStudentData(callback: (pctLoaded) {
    print('${pctLoaded * 100}% loaded');
  });
  print(studentData.toString());
}
0
likes
0
pub points
1%
popularity

Publisher

unverified uploader

a client library for the student vue grade system

Repository (GitHub)
View/report issues

License

unknown (LICENSE)

Dependencies

dio, html_unescape, xml

More

Packages that depend on studentvueclient