strophe 0.0.5

  • Readme
  • Changelog
  • Installing
  • 14

Strophe-dart is a pure Dart library for speaking XMPP via BOSH (XEP 124 and XEP 206) and WebSockets (RFC 7395).

Its primary purpose is to enable mobile-based(flutter),desktop and web-based, real-time XMPP applications.

The book Professional XMPP Programming with JavaScript and jQuery covers Strophe.Js in detail in the context of web applications.


Bosh and all authenticate mechanisms don't work for the moment .

License It is licensed under the MIT license, except for the files sha1.js, base64.js and md5.js, which are licensed as public domain and BSD (see these files for details).

Author & History Strophe.js was originally created by Jack Moffitt. It was originally developed for Chesspark, an online chess community based on XMPP technology. It has been cared for and improved over the years and is currently maintained by many people in the community.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  strophe: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:strophe/strophe.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 21, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.7.0.
 Because strophe requires SDK version >=1.19.0 <=2.1.0, version solving failed.

Health suggestions

Format lib/src/enums.dart.

Run flutter format to format lib/src/enums.dart.

Format lib/src/plugins/bookmark.dart.

Run flutter format to format lib/src/plugins/bookmark.dart.

Format lib/src/plugins/chat-notifications.dart.

Run flutter format to format lib/src/plugins/chat-notifications.dart.

Fix additional 8 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/plugins/disco.dart (Run flutter format to format lib/src/plugins/disco.dart.)
  • lib/src/plugins/last-activity.dart (Run flutter format to format lib/src/plugins/last-activity.dart.)
  • lib/src/plugins/muc.dart (Run flutter format to format lib/src/plugins/muc.dart.)
  • lib/src/plugins/privacy.dart (Run flutter format to format lib/src/plugins/privacy.dart.)
  • lib/src/plugins/private-storage.dart (Run flutter format to format lib/src/plugins/private-storage.dart.)
  • lib/src/plugins/pubsub.dart (Run flutter format to format lib/src/plugins/pubsub.dart.)
  • lib/src/plugins/register.dart (Run flutter format to format lib/src/plugins/register.dart.)
  • lib/src/plugins/roster.dart (Run flutter format to format lib/src/plugins/roster.dart.)

Maintenance issues and suggestions

Support future stable Dart 2 SDKs in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow future stable Dart 2.x SDK releases.

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Package is getting outdated. (-42.74 points)

The package was last published 74 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and strophe.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <=2.1.0