stripe_widget 0.0.4

  • Readme
  • Changelog
  • Example
  • Installing
  • 62

Stripe Widget #

A flutter plugin to integrate the stripe plugin for iOS and Android. Currently only adding a credit card as source is implemented.

Usage #

To set your publishable key set:

import 'package:stripe_widget/stripe_widget.dart';

from somewhere in your code, e.g. your main.dart file.

To open the dialog:

StripeWidget.addSource().then((String token) {
    print(token); //your stripe card source token

0.0.1 #

  • TODO: Describe initial release.


stripe_widget_example #

Demonstrates how to use the stripe_widget plugin.

Getting Started #


Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  stripe_widget: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:stripe_widget/stripe_widget.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 20, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Format lib/stripe_widget.dart.

Run flutter format to format lib/stripe_widget.dart.

Maintenance suggestions

Package is getting outdated. (-15.62 points)

The package was last published 60 weeks ago.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8