stream_store 0.1.0

  • Readme
  • Changelog
  • Installing
  • 0

stream_store #

Build Status codecov

Redux-style state management built with Dart Primitives. The Store is a simple Stream<State> and a Sink<Action>. This means you can add (aka dispatch) new actions to the Sink<Action>.

If you add an action, it will then run through the provided reducer. Reducers are pure functions that should only update the state in response to actions. The updated state will then be emitted to anything that is listening to the Store's Stream<State>.

If you need to perform side-effects, such as communicating with a web server or database, you can write an Effect. Each effect will receive the Stream<State> and the Stream<Action>. You can then use these streams to make async calls in response to an action.

Disclaimer #

I have no idea if anyone wants to use this or if it's even necessary given the fact that there are other Dart Redux solutions out there, but I did it as a thought experiment to see how close to the core Dart primitives we could get and thought I might as well publish it.

Changelog #

0.1.0 #

  • Breaking changes: Remove state transformers. You an just transform the Store's Stream<State> however you like.
  • Only allow the use of Effect for side-effects instead of transformers. Effects cannot swallow actions that are added to the Stream, and work with both a Stream<Action> and a Stream<State>.
  • Migrate LoggingTransformer to LoggingEffect. Improve functionality.

0.0.2 #

  • Move to github
  • Bump Rx

0.0.1 #

  • Initial version with simple Stream-based API

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  stream_store: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:stream_store/stream_store.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.21.0 <2.0.0