stream_reader 1.0.2

stream_reader #

version 1.0.2 build status

Asynchronously read from Dart streams. Supports peeking, reading, and a reference to the current element.

Usage #

import 'dart:async';
import 'package:stream_reader/stream_reader.dart';
import 'package:test/test.dart';

Stream<String> strings() async* {
  yield 'Michael';
  yield 'Jackson';
  yield 'Bernie';
  yield 'Sanders';

main() {
  test('read', () async {
    // Read two
    var reader = new StreamReader<String>()..addStream(strings());
    await reader.consume();
    var str = await reader.consume();
    expect(str, equals('Jackson'));

  test('peek+current', () async {
    // Read two
    var reader = new StreamReader<String>()..addStream(strings());
    await reader.consume();
    await reader.consume();
    var peek = await reader.peek();
    expect(peek, equals('Bernie'));

    // current should still be second string
    var str = await reader.current();
    expect(str, equals('Jackson'));

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  stream_reader: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:stream_reader/stream_reader.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0