statusbar_util 1.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 79

statusbar_util #

A flutter plugin to set statusbar transparent.support android 4.4+ && ios.

Getting Started #

dependencies:
    statusbar_util: ^newest

Usage #

import 'package:statusbar_util/statusbar_util.dart';

void main() {
  // setTranslucent
  StatusbarUtil.setTranslucent();
  
  // setStatusBarFontStyle
  StatusbarUtil.setStatusBarFont(FontStyle.black); // black text
  StatusbarUtil.setStatusBarFont(FontStyle.white); // white text
  runApp(MyApp());
}

1.0.1 #

add setStatusBarFont

1.0.0 #

release 1.0.0

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:statusbar_util/statusbar_util.dart';

void main() {
  WidgetsFlutterBinding.ensureInitialized();
  StatusbarUtil.setTranslucent();
  runApp(MyApp());
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';

  @override
  void initState() {
    super.initState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Column(
          children: <Widget>[
            RaisedButton(
              child: Text('black'),
              onPressed: () {
                StatusbarUtil.setStatusBarFont(FontStyle.black);
              },
            ),
            RaisedButton(
              child: Text('white'),
              onPressed: () {
                StatusbarUtil.setStatusBarFont(FontStyle.white);
              },
            ),
          ],
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  statusbar_util: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:statusbar_util/statusbar_util.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
57
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
79
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:statusbar_util/statusbar_util.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:statusbar_util/statusbar_util.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:statusbar_util/statusbar_util.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:statusbar_util/statusbar_util.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • statusbar_util that is a package requiring null.

Health suggestions

Format lib/generated/i18n.dart.

Run flutter format to format lib/generated/i18n.dart.

Format lib/statusbar_util.dart.

Run flutter format to format lib/statusbar_util.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test