statusbar 1.1.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 85

statusbar #

With this plugin you can easily change the color behind the status bar for both iOS and Android with a single line of code.

Note: This plugin does not change the tint of the items on the statusbar, only the background.

How to Use #

StatusBar.color(Colors.red);

1.1.0 #

  • (Android) Updated to AndroidX.

1.0.8 #

  • (Android) Resolved crashes for android versions before lollipop.

1.0.7 #

  • (iOS) Now listening for status bar updates in UIApplication's public API.

1.0.6 #

  • Reverted back because of swizzling non-public api, causing apps to be rejected.

1.0.5 #

  • (iOS) Now listening for status bar updates in UIApplication.

1.0.4 #

  • Resolved issue in iOS, not updating properly if VC implements prefersStatusBarHidden.

1.0.3 #

  • Resolved issue in Android not padding hex color value with 0.

1.0.2 #

  • Switched from Swift -> ObjC, attempting to solve issue when including plugin

1.0.1 #

  • Added iOS, Android and example folders

1.0.0 #

  • Change status bar color support

example/README.md

statusbar_example #

Demonstrates how to use the statusbar plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  statusbar: ^1.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:statusbar/statusbar.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
79
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
85
Learn more about scoring.

We analyzed this package on Nov 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

4 out of 4 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/statusbar.dart.

Run flutter format to format lib/statusbar.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8