states 0.9.21

Dart native js
Flutter Android iOS web

States is Finite State Machine for Dart. You can define states of your application and reaction on transition between states

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  states: ^0.9.21

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:states/states.dart';
0
likes
90
pub points
0%
popularity

States is Finite State Machine for Dart. You can define states of your application and reaction on transition between states

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

vladimir.cores@gmail.com

License

unknown (LICENSE)

More

Packages that depend on states