state_notifier 0.1.0

Dart native js
Flutter Android iOS web

ValueNotifier, but outside Flutter and with some extra perks

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  state_notifier: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:state_notifier/state_notifier.dart';
91
likes
100
pub points
96%
popularity

Publisher

dash-overflow.net

ValueNotifier, but outside Flutter and with some extra perks

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

meta

More

Packages that depend on state_notifier