stanza 0.0.13

stanza #

README

Stanza Changelog #

0.0.10 #

  • Added changelog!
  • Added example

0.0.11 #

  • Removed unused dependency

0.0.12 #

  • Fixed date comparisons in where clauses.
  • Added raw string condition for where clauses.

0.0.13 #

  • Fixed issue in where clauses with substitution values not allowing periods in qualified field names.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  stanza: ^0.0.13

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:stanza/stanza.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
28
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
60
Learn more about scoring.

We analyzed this package on Feb 12, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (recase).

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and stanza.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
pool ^1.4.0 1.4.0
postgres ^2.0.0 2.1.0
recase ^2.0.1 2.0.1 3.0.0
Transitive dependencies
async 2.4.0
buffer 1.0.6
charcode 1.1.3
collection 1.14.12
convert 2.1.1
crypto 2.1.4
path 1.6.4
stack_trace 1.9.3
typed_data 1.1.6
Dev dependencies
build_runner any
pedantic any