stagexl_dragonbones 0.3.1

StageXL_DragonBones #

The DragonBones runtime for the StageXL library.

DragonBones is an open source 2D skeleton animation solution very popular among Flash and Starling developers. The editor is available for Mac and Windows and does not require Adobe Flash Pro. Find more information here: https://dragonbones.github.io/

NOTE: as of version 0.3.0-dev, StageXL_DragonBones requires a Dart 2 SDK.

##Examples

http://www.stagexl.org/show/dragonbones/dragon/example.html http://www.stagexl.org/show/dragonbones/dragon_new/example.html http://www.stagexl.org/show/dragonbones/swords_man/example.html http://www.stagexl.org/show/dragonbones/demon/example.html http://www.stagexl.org/show/dragonbones/ubbie/example.html

##Runtime

This runtime started as a direct port of the original AS3 runtime for DragonBones. Unfortunately the original runtime is quite complex and difficult to read. Therefore we decided to implement the DragonBones runtime for StageXL from scratch. This should make it easier to maintain the runtime, fix bugs and add new features. The drawback is that we don't support all the features of the original runtime yet. Please open new issues with your favorite runtime feature we should add next.

Changelog #

This file contains highlights of what changes on each version of the StageXL_DragonBones package. This file is normally updated whenever we push a new version to pub.

0.3.1 #

  • Raised dependency to StageXL 1.4.1
  • Ready for Dart 2.4

0.3.0 #

  • Raised dependency to StageXL 1.4.0
  • Ready for Dart 2.0

0.2.2 #

  • Raised dependency to StageXL 1.0.0

0.2.1 #

  • Simplified animation easing code.
  • Support for DragonBones 4.6 export format changes.

0.2.0 #

  • Added support for meshes.
  • Added support for free form deformations.
  • Support for DragonBones 4.5 (without IK)

0.1.0 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  stagexl_dragonbones: ^0.3.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:stagexl_dragonbones/stagexl_dragonbones.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
39
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
83
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Aug 23, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: web

Primary library: package:stagexl_dragonbones/stagexl_dragonbones.dart with components: html.

Health suggestions

Format lib/src/data/animation.dart.

Run dartfmt to format lib/src/data/animation.dart.

Format lib/src/data/animation_object.dart.

Run dartfmt to format lib/src/data/animation_object.dart.

Format lib/src/data/animation_object_frame.dart.

Run dartfmt to format lib/src/data/animation_object_frame.dart.

Fix additional 29 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/data/armature.dart (Run dartfmt to format lib/src/data/armature.dart.)
  • lib/src/data/bone/bone.dart (Run dartfmt to format lib/src/data/bone/bone.dart.)
  • lib/src/data/bone/bone_animation.dart (Run dartfmt to format lib/src/data/bone/bone_animation.dart.)
  • lib/src/data/bone/bone_animation_frame.dart (Run dartfmt to format lib/src/data/bone/bone_animation_frame.dart.)
  • lib/src/data/display.dart (Run dartfmt to format lib/src/data/display.dart.)
  • lib/src/data/mesh/mesh.dart (Run dartfmt to format lib/src/data/mesh/mesh.dart.)
  • lib/src/data/mesh/mesh_animation.dart (Run dartfmt to format lib/src/data/mesh/mesh_animation.dart.)
  • lib/src/data/mesh/mesh_animation_frame.dart (Run dartfmt to format lib/src/data/mesh/mesh_animation_frame.dart.)
  • lib/src/data/skin.dart (Run dartfmt to format lib/src/data/skin.dart.)
  • lib/src/data/skin_slot.dart (Run dartfmt to format lib/src/data/skin_slot.dart.)
  • lib/src/data/slot/slot.dart (Run dartfmt to format lib/src/data/slot/slot.dart.)
  • lib/src/data/slot/slot_animation.dart (Run dartfmt to format lib/src/data/slot/slot_animation.dart.)
  • lib/src/data/slot/slot_animation_frame.dart (Run dartfmt to format lib/src/data/slot/slot_animation_frame.dart.)
  • lib/src/dragon_bones.dart (Run dartfmt to format lib/src/dragon_bones.dart.)
  • lib/src/dragon_bones_parser_json4.dart (Run dartfmt to format lib/src/dragon_bones_parser_json4.dart.)
  • lib/src/math/curve.dart (Run dartfmt to format lib/src/math/curve.dart.)
  • lib/src/math/transform.dart (Run dartfmt to format lib/src/math/transform.dart.)
  • lib/src/skeleton/bone/skeleton_bone.dart (Run dartfmt to format lib/src/skeleton/bone/skeleton_bone.dart.)
  • lib/src/skeleton/bone/skeleton_bone_animation.dart (Run dartfmt to format lib/src/skeleton/bone/skeleton_bone_animation.dart.)
  • lib/src/skeleton/display/skeleton_display.dart (Run dartfmt to format lib/src/skeleton/display/skeleton_display.dart.)
  • lib/src/skeleton/display/skeleton_display_armature.dart (Run dartfmt to format lib/src/skeleton/display/skeleton_display_armature.dart.)
  • lib/src/skeleton/display/skeleton_display_image.dart (Run dartfmt to format lib/src/skeleton/display/skeleton_display_image.dart.)
  • lib/src/skeleton/display/skeleton_display_mesh.dart (Run dartfmt to format lib/src/skeleton/display/skeleton_display_mesh.dart.)
  • lib/src/skeleton/display/skeleton_display_mesh_animation.dart (Run dartfmt to format lib/src/skeleton/display/skeleton_display_mesh_animation.dart.)
  • lib/src/skeleton/skeleton.dart (Run dartfmt to format lib/src/skeleton/skeleton.dart.)
  • lib/src/skeleton/skeleton_object.dart (Run dartfmt to format lib/src/skeleton/skeleton_object.dart.)
  • lib/src/skeleton/skeleton_object_animation.dart (Run dartfmt to format lib/src/skeleton/skeleton_object_animation.dart.)
  • lib/src/skeleton/slot/skeleton_slot.dart (Run dartfmt to format lib/src/skeleton/slot/skeleton_slot.dart.)
  • lib/src/skeleton/slot/skeleton_slot_animation.dart (Run dartfmt to format lib/src/skeleton/slot/skeleton_slot_animation.dart.)

Maintenance suggestions

The package description is too short. (-12 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and stagexl_dragonbones.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.4.0 <3.0.0
stagexl >=1.4.1 <2.0.0 1.4.1
Transitive dependencies
charcode 1.1.2
collection 1.14.12
convert 2.1.1
meta 1.1.7
petitparser 2.4.0
typed_data 1.1.6
xml 3.5.0
Dev dependencies
build_runner any
build_test any
build_web_compilers any
pedantic any