stage 0.0.2

  • Readme
  • Changelog
  • Installing
  • 40

stage #

Build arbitrarily complex layout with imperative code.

Getting Started #


import 'package:stage/stage.dart';

/// use Stage widget in your widget: 

Widget build(BuildContext context) {
    return Stage<int>(
        itemBuilder: (context, int layer) {
          return Text('$layer',
              textDirection: TextDirection.ltr, key: Key('$layer'));
        },
        stageBuilder: (constraints, selectItem) {
          final List<RenderBox> items = [
            selectItem(1),
            selectItem(2),
            selectItem(3),
          ];

          items.forEach((item) => item.layout(constraints));

          final data =
              items.map((item) => item.parentData as StageParentData).toList();

          data[0].offset = Offset(10, 10);
          data[1].offset = Offset(20, 20);
          data[2].offset = Offset(30, 30);

          return constraints.biggest;
        },
    );
}

Stage will render 3 Text widgets, with corresponding offset.

[0.0.1] #

  • Initial release.

[0.0.2] #

  • Add homepage.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  stage: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:stage/stage.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
54
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

because of import path [stage] that is in a package requiring null.

Health suggestions

Fix lib/stage.dart. (-2.48 points)

Analysis of lib/stage.dart reported 5 hints:

line 38 col 17: The member '==' is declared non-virtual in 'Widget' and can't be overridden in subclasses.

line 47 col 11: The member 'hashCode' is declared non-virtual in 'Widget' and can't be overridden in subclasses.

line 164 col 8: This method overrides a method annotated as '@mustCallSuper' in 'Element', but doesn't invoke the overridden method.

line 351 col 17: The member '==' is declared non-virtual in 'Widget' and can't be overridden in subclasses.

line 360 col 11: The member 'hashCode' is declared non-virtual in 'Widget' and can't be overridden in subclasses.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/pinyin/stage was unreachable.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and stage.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-6 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test