sso 0.2.0

  • Readme
  • Changelog
  • Installing
  • new66

dart-sso #

Simple Single Sign-On abstract library

[0.2.0] v0.2.0

  • Refactor sso
  • Add UserConverter and WillConvertUser
  • Move ActionButton to identity package
  • Remove header and theme in Provider

[0.1.2] v0.1.2

  • Add default notifier for WillNotify
  • Add notify to WillNotify as a proxy method

[0.1.1] v0.1.1

  • Set default notifier for provider

[0.1.0] v0.1.0

  • Add Notifier and WillNotify
  • Modified constructor of Provider

[0.0.9] v0.0.9

  • Improve Provider#notify

[0.0.8] v0.0.8

  • Add method notify for Provider

[0.0.7] v0.0.7

  • Change action button icon's type to Widget

[0.0.6] v0.0.6

  • Change signature of Provider#use
  • Add theme and header to Provider

[0.0.5] - v0.0.5

  • Add default constructor for Provider
  • Change signature of Authenticator#authenticate

[0.0.4] - v0.0.4

  • Change parameters to optional argument

[0.0.3] - v0.0.3

  • Change return type of action
  • Use getter instead of method

[0.0.2] - v0.0.2

  • Add ActionButton, Authenticator, Provider and Uesr
  • Add tests for User

[0.0.1] - v0.0.1

  • Init project

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sso: ^0.2.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sso/sso.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
40
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
79
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Maintenance suggestions

The package description is too short. (-11 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and sso.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test