squares 1.1.3 icon indicating copy to clipboard operation
squares: ^1.1.3 copied to clipboard

A flexible chessboard widget for Flutter. Visually customisable, with support for many chess variants.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add squares

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  squares: ^1.1.3

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:squares/squares.dart';
15
likes
130
pub points
63%
popularity

Publisher

unverified uploader

A flexible chessboard widget for Flutter. Visually customisable, with support for many chess variants.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

badges, equatable, flutter

More

Packages that depend on squares