sqflite_common 2.0.0+2
sqflite_common: ^2.0.0+2 copied to clipboard

Dart wrapper on SQLite, a self-contained, high-reliability, embedded, SQL database engine.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add sqflite_common

With Flutter:

 $ flutter pub pub add sqflite_common

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  sqflite_common: ^2.0.0+2

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:sqflite_common/sqflite_dev.dart';
import 'package:sqflite_common/sql.dart';
import 'package:sqflite_common/sqlite_api.dart';
import 'package:sqflite_common/utils/utils.dart';
21
likes
130
pub points
100%
popularity

Dart wrapper on SQLite, a self-contained, high-reliability, embedded, SQL database engine.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

alex@tekartik.com

License

MIT (LICENSE)

Dependencies

meta, path, synchronized

More

Packages that depend on sqflite_common