sprintf 3.0.2

  • README.md
  • Installing
  • Versions
  • 48

dart-sprintf #

Dart implementation of sprintf.

Build Status

ChangeLog #

v3.0.2 (2017-08-17

* Fixed bad publish

v3.0.1 (2017-08-17)

* Fixed weak typing which stopped dartdevc from working (#11 thanks @bergwerf)

v3.0.0 (2017-04-20)

* Fixed rounding of floats, again. Bumping major version because it's different from previous behaviour

v2.0.0 (2017-03-23)

* Fixed rounding of floats. Bumping major version, because previous behaviour was to always round down.

v1.1.1 (2016-11-16)

* Updated to use `test` library since `unittest` has been deprecated. 

v1.1.0 (2014-08-21)

* **API change**: Any object with a valid `toString` method can be formatted with `'%s'` (#7)

v1.0.9 (2013-12-15)

* Round numbers when they're truncated. (#6)

v1.0.8 (2013-10-08)

* Remove trailing decimal point if there are no following digits (#6)

v1.0.7 (2013-05-07)

* Update for new dart version

v1.0.6 (2013-04-16)

* Update for new dart version

v1.0.5 (2013-03-25)

* Fixed dependencies example in README (#5)

v1.0.4 (2013-03-21)

* Update for new dart version

* Update for new pubspec format

v1.0.3 (2013-02-12)

* Update for dart M2

v1.0.2 (2013-01-21)

* Pubspec and whitespace fixes

v1.0.1 (2012-11-12)

* Update for new dart version

v1.0.0 (2012-10-08)

First release with semver

Getting Started #

Add the following to your pubspec.yaml:

dependencies:
  sprintf: "^3.0.0"

then run pub install.

Next, import dart-sprintf:

import 'package:sprintf/sprintf.dart';

Example #

import 'package:sprintf/sprintf.dart';

void main() {
	print(sprintf("%04i", [-42]));
	print(sprintf("%s %s", ["Hello", "World"]));
	print(sprintf("%#04x", [10]));
}
-042
Hello World
0x0a

Limitations #

  • Negative numbers are wrapped as 64bit ints when formatted as hex or octal.

Differences to C's printf

  • When using fixed point printing of numbers with large exponents, C introduces errors after 20 decimal places. Dart-printf will just print 0s.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sprintf: ^3.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sprintf/sprintf.dart';
  
Version Uploaded Documentation Archive
4.0.2 Feb 20, 2019 Go to the documentation of sprintf 4.0.2 Download sprintf 4.0.2 archive
4.0.1 Feb 19, 2019 Go to the documentation of sprintf 4.0.1 Download sprintf 4.0.1 archive
4.0.0 Jul 28, 2018 Go to the documentation of sprintf 4.0.0 Download sprintf 4.0.0 archive
3.0.2 Aug 18, 2017 Go to the documentation of sprintf 3.0.2 Download sprintf 3.0.2 archive
3.0.1 Aug 18, 2017 Go to the documentation of sprintf 3.0.1 Download sprintf 3.0.1 archive
3.0.0 Apr 20, 2017 Go to the documentation of sprintf 3.0.0 Download sprintf 3.0.0 archive
1.0.8 Oct 9, 2013 Go to the documentation of sprintf 1.0.8 Download sprintf 1.0.8 archive
1.0.7 May 7, 2013 Go to the documentation of sprintf 1.0.7 Download sprintf 1.0.7 archive
1.0.6 Apr 16, 2013 Go to the documentation of sprintf 1.0.6 Download sprintf 1.0.6 archive
1.0.5 Mar 29, 2013 Go to the documentation of sprintf 1.0.5 Download sprintf 1.0.5 archive

All 15 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
96
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.