sprintf 6.0.0 icon indicating copy to clipboard operation
sprintf: ^6.0.0 copied to clipboard

Dart implementation of sprintf. Provides simple printf like formatting such as sprintf("hello %s", ["world"]);

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add sprintf

With Flutter:

 $ flutter pub add sprintf

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  sprintf: ^6.0.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:sprintf/sprintf.dart';
72
likes
110
pub points
98%
popularity

Dart implementation of sprintf. Provides simple printf like formatting such as sprintf("hello %s", ["world"]);

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE.md)

More

Packages that depend on sprintf