spotlight_carousel 0.1.1

spotlight_carousel #

A Flutter widget for displaying images in a carousel style with an optional page indicator. See the demonstration here.

example screenshot

Getting Started #

To include in your Flutter project, import the base Dart file.

import 'package:spotlight_carousel/spotlight_carousel.dart';

Then, add the widget to your build method.

SpotlightCarousel(
    images: images,
    titles, titles,
    descriptions, descriptions,    
);

[0.1.1]

  • Fixed backwards bug

[0.1.0]

  • Added image to description
  • Added option for custom ScrollController

[0.0.2]

  • Fixed README

[0.0.1]

  • Cleaned up code and packaged for initial release!

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  spotlight_carousel: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:spotlight_carousel/spotlight_carousel.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
60
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
78
Learn more about scoring.

We analyzed this package on Aug 18, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and spotlight_carousel.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test