speedometer 1.0.8

SpeedOMeter #

A little widget that given an Observable gives you an updated SpeedOMeter.


Getting Started #

You should ensure that you add the following dependency in your Flutter project.

dependencies:
 speedometer: "^1.0.1"

You should then run flutter packages upgrade or update your packages in IntelliJ.

In your Dart code, to use it:

import 'package:speedometer/speedometer.dart';

Example #

An example can be found in the example folder. Check it out.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

example/README.md

example #

A SpeedOMeter example for flutter

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  speedometer: ^1.0.8

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:speedometer/speedometer.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
71
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
81
Learn more about scoring.

We analyzed this package on Feb 18, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health suggestions

Fix lib/speedometer.dart. (-1.49 points)

Analysis of lib/speedometer.dart reported 3 hints:

line 13 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: SpeedOMeter.start, SpeedOMeter.end, SpeedOMeter.highlightStart, SpeedOMeter.highlightEnd, SpeedOMeter.themeData, SpeedOMeter.eventObservable

line 27 col 30: Use ; instead of {} for empty constructor bodies.

line 46 col 30: Cancel instances of dart.async.StreamSubscription.

Format lib/handpainter.dart.

Run flutter format to format lib/handpainter.dart.

Format lib/linepainter.dart.

Run flutter format to format lib/linepainter.dart.

Format lib/speedtextpainter.dart.

Run flutter format to format lib/speedtextpainter.dart.

Maintenance issues and suggestions

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: rxdart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
rxdart >=0.18.1 0.23.1
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test