speech 0.0.3+1

  • Readme
  • Changelog
  • Example
  • Installing
  • 66

speech #

[NOT WORKING]

0.0.1 #

  • Basic model, currently returns a bunch of dummy text

0.0.2 #

  • Updated Plugin description

0.0.3 #

  • Implemented streaming [UNSTABLE]
  • Added permission to read files from file system, as is needed to read credentials file on the phone

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:speech/speech.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _text = "";
  int _index = 0;
  StreamSubscription<dynamic> listener;

  var _icon = [
    new Icon(Icons.keyboard_voice),
    new Icon(Icons.stop),
  ];

  var _color = [
    Colors.cyan,
    Colors.red
  ];

  void _buttonPressed() async {
    if (_index == 0) listener = transcript("/storage/emulated/0/Download/hypnote.json").listen((data) => _append(data), onError: (error) => print(error));
    else listener.cancel();
    _switchButton();
  }

  void _switchButton() => setState(() => _index = (_index + 1) % 2);
  void _append(String text) => setState(() => _text += text);


  @override
  void initState() {
    super.initState();
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Life Transcript'),
          backgroundColor: Colors.cyan,
        ),
        body: Center(
          child: new Text(_text),
        ),
        floatingActionButton: FloatingActionButton(
          child: _icon[_index],
          backgroundColor: _color[_index],
          onPressed: _buttonPressed,
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  speech: ^0.0.3+1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:speech/speech.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
39
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Mar 31, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Format lib/speech.dart.

Run flutter format to format lib/speech.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The description is too long. (-10 points)

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
permission ^0.1.1 0.1.7
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test