This project implements a Dart pub package to work with source maps. The implementation is based on the source map version 3 spec which was originated from the Closure Compiler and has been implemented in Chrome and Firefox.
In this package we provide:
Some upcoming features we are planning to add to this package are:
MappingBundle.spanForhandling of URIs that have a suffix that exactly match a source map in the MappingBundle.
MappingBundle.spanForto accept requests for output files that don't have source maps.
MappingBundleclass that handles extended source map format that supports source maps for multiple output files in a single mapper. Extend
Mapping.spanForAPI to accept a uri parameter that is optional for normal source maps but required for MappingBundle source maps.
mapUrlnamed argument to
parseJson. This argument is used to resolve source URLs for source spans.
SourceFileclasses. Use the corresponding
All methods that take
SourceFiles as inputs now
also accept the corresponding
source_span classes as well. Using the old
classes is now deprecated and will be unsupported in version 0.10.0.
sourceRootfield in the SingleMapping class.
targetUrlfield in the SingleMapping class.
Support unmapped areas in source maps.
Increase the readability of location messages.
Add this to your package's pubspec.yaml file:
dependencies: source_maps: ^0.10.3
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.10.8||Oct 3, 2018|
|0.10.7||Jul 17, 2018|
|0.10.6||Jun 26, 2018|
|0.10.5||Apr 25, 2018|
|0.10.4||Mar 23, 2017|
|0.10.3||Mar 7, 2017|
|0.10.2||Dec 14, 2016|
|0.10.1+5||Dec 12, 2016|
|0.10.1+4||Dec 9, 2016|
|0.10.1+3||Dec 8, 2016|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.8.0 <2.0.0|