source_gen 1.1.0
source_gen: ^1.1.0 copied to clipboard

Source code generation builders and utilities for the Dart build system

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add source_gen

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  source_gen: ^1.1.0

Alternatively, your editor might support dart pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:source_gen/source_gen.dart';
49
likes
100
pub points
99%
popularity

Publisher

tools.dart.dev

Source code generation builders and utilities for the Dart build system

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

analyzer, async, build, dart_style, glob, meta, path, pedantic, source_span, yaml

More

Packages that depend on source_gen