snapdart 0.1.2

  • Readme
  • Changelog
  • Installing
  • 50

Snapdart #

License: MIT

Overview #

Snapcast client for Dart

0.1.2 #

Fix bug on deserilization

0.1.1 #

Code improvement

0.1.0 #

Initial Version of the library.

  • Include the possibility to connect to a Snapcast Server and make some basic request

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  snapdart: ^0.1.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:snapdart/snapdart.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
15
Health:
Code health derived from static analysis. [more]
95
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4

Health issues and suggestions

Document public APIs. (-1 points)

157 out of 157 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/remote_control.dart. (-3.93 points)

Analysis of lib/remote_control.dart reported 8 hints, including:

line 37 col 25: Unnecessary new keyword.

line 39 col 48: Unnecessary new keyword.

line 40 col 62: Unnecessary new keyword.

line 46 col 18: Unnecessary new keyword.

line 113 col 17: Avoid empty catch blocks.

Fix lib/tcp_client.dart. (-0.50 points)

Analysis of lib/tcp_client.dart reported 1 hint:

line 6 col 25: Unnecessary new keyword.

Format lib/models/snap_stream.dart.

Run dartfmt to format lib/models/snap_stream.dart.

Format lib/snapdart.dart.

Run dartfmt to format lib/snapdart.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and snapdart.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
logging ^0.11.3+2 0.11.4
Dev dependencies
mockito ^4.0.0
test >=1.3.0 <2.0.0
test_coverage ^0.2.0