sms_consent 0.0.5

  • Readme
  • Changelog
  • Example
  • Installing
  • 66

sms_consent #

A Flutter plugin that enable the use of SMS User Consent API.

Only Android Support #

Since iOS have his own way to make easier to users to input the incoming OTP, this package only target the ANDROID OS.

To understand the flow and the API check this link

Installation #

Just follow the basic installation of any flutter plugin by adding the package to the project's pubspec.yaml.

On your Flutter project # See the installation instructions on pub.

Using this amazing plugin #

It's a very easy thing, trust me. With just 1 line you make the SMS User Consent API work on your app.

await SmsConsent.startSMSConsent(senderPhoneNumber: '321321312');

OR

await SmsConsent.startSMSConsent();

Part of the journey is the end #

When you ended with the plugin, is important to stop the Consent Service. Not calling the method below may result in unexpected behaviour in your app!

await SmsConsent.stopSMSConsent();

Considerations #

You need to call the plugin before requesting the OTP, since the SMS User Consent API will ONLY show SMS that are received after the initialization of it. In other words: the API doesn't show old messages.

0.0.1 #

  • Initial release with the MVP of the plugin.

0.0.2 #

  • Fixed README.md

0.0.3 #

  • Fixed channel name on plugin

0.0.4 #

  • Added method to cancel the listener to the User SMS Consent API

0.0.5 #

  • Fixed the empty configuration for iOS. (The was causing the build to fail)

example/README.md

flutter_sms_consent_example #

Demonstrates how to use the flutter_sms_consent plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sms_consent: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sms_consent/sms_consent.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
36
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Dec 13, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.1+4
  • Flutter: 1.12.13+hotfix.4

Health issues and suggestions

Document public APIs. (-1 points)

5 out of 5 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/sms_consent.dart.

Run flutter format to format lib/sms_consent.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test