smart_arg 1.1.1

Dart native
Flutter Android iOS

A smart command line argument parser for Dart that provides argument validation, static type checking, command execution, beautiful help generation and more.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  smart_arg: ^1.1.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:smart_arg/smart_arg.dart';
4
likes
100
pub points
29%
popularity

A smart command line argument parser for Dart that provides argument validation, static type checking, command execution, beautiful help generation and more.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

jcowgar@gmail.com

License

MIT (LICENSE)

Dependencies

path, reflectable

More

Packages that depend on smart_arg