skt 0.0.22

  • Readme
  • Changelog
  • Example
  • Installing
  • 44

skt #

Flutter plugin project for supporting SKT Maps

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

skt-maps #

Build Status

Table of Contents #

Quick Start #

Get all packages #

  • For a single package, just run flutter packages get
  • To pull for all the packages in the project, run dart ./scripts/cli/cli.dart getPackages

Run the Linter / Dart Analyzer / Formatter #

On the root, run dartanalyzer --fatal-infos --fatal-warnings .

Format #

On the root, run dartfmt -w .

Run the tests #

Unit and Widget tests #

  • Run: flutter test

Get code coverage report #

  • On Jenkins, on every build there will be an option called Test Coverage Report that will display the report for the given build.
  • Locally:
    • Make sure you have lcov installed (On MacOS, brew install lcov).
    • Run unit tests with coverage and generate the HTML report: ./scripts/pipeline/generate_coverage.sh .
    • Open ./coverage/html_report/index.html in your browser. Enjoy it! ;)

Getting Started #

For help getting started with Flutter, view our online documentation.

0.0.2 #

  • change API_KEY

0.0.21 #

  • class name change

0.0.22 #

example/README.md

skt_example #

Demonstrates how to use the skt plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  skt: ^0.0.22

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:skt/skt.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Nov 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/src/map.dart. (-0.50 points)

Analysis of lib/src/map.dart reported 1 hint:

line 41 col 18: The value of the field '_sktMapOptions' isn't used.

Format lib/skt.dart.

Run flutter format to format lib/skt.dart.

Format lib/src/camera.dart.

Run flutter format to format lib/src/camera.dart.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/controller.dart (Run flutter format to format lib/src/controller.dart.)
  • lib/src/location.dart (Run flutter format to format lib/src/location.dart.)
  • lib/src/ui.dart (Run flutter format to format lib/src/ui.dart.)

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.47.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
build_runner ^1.0.0
flutter_driver
flutter_test
mockito 4.0.0
test ^1.6.0