singleton_class_generator 0.1.0+1

  • Readme
  • Changelog
  • Installing
  • 43

singleton_class_generator #

A singleton class generator for singleton_class_annotation. See the details in the singleton_class_annotation.

[0.1.0+1] #

  • typo

[0.1.0] #

  • First generator.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  singleton_class_generator: ^0.1.0+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:singleton_class_generator/singleton_class_generator.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
1
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1

Analysis suggestions

Package not compatible with SDK dart

because of import path [singleton_class_generator, singleton_class_annotation]

Package not compatible with SDK flutter

Because it is not compatible with any of the supported runtimes: flutter-native, flutter-web

Package not compatible with runtime flutter-native of android

Because of the import of dart:mirrors via the import chain package:singleton_class_generator/singleton_class_generator.dart->package:singleton_class_generator/src/singleton_builder.dart->package:source_gen/source_gen.dart->package:source_gen/src/type_checker.dart->dart:mirrors

Package not compatible with runtime flutter-native of ios

Because of the import of dart:mirrors via the import chain package:singleton_class_generator/singleton_class_generator.dart->package:singleton_class_generator/src/singleton_builder.dart->package:source_gen/source_gen.dart->package:source_gen/src/type_checker.dart->dart:mirrors

Package not compatible with runtime flutter-native of linux

Because of the import of dart:mirrors via the import chain package:singleton_class_generator/singleton_class_generator.dart->package:singleton_class_generator/src/singleton_builder.dart->package:source_gen/source_gen.dart->package:source_gen/src/type_checker.dart->dart:mirrors

Package not compatible with runtime flutter-native of macos

Because of the import of dart:mirrors via the import chain package:singleton_class_generator/singleton_class_generator.dart->package:singleton_class_generator/src/singleton_builder.dart->package:source_gen/source_gen.dart->package:source_gen/src/type_checker.dart->dart:mirrors

Package not compatible with runtime flutter-native of windows

Because of the import of dart:mirrors via the import chain package:singleton_class_generator/singleton_class_generator.dart->package:singleton_class_generator/src/singleton_builder.dart->package:source_gen/source_gen.dart->package:source_gen/src/type_checker.dart->dart:mirrors

Package not compatible with runtime flutter-web of web

Because of the import of dart:io via the import chain package:singleton_class_generator/singleton_class_generator.dart->package:singleton_class_generator/src/singleton_builder.dart->package:source_gen/source_gen.dart->package:source_gen/src/utils.dart->package:build/build.dart->package:build/src/generate/run_post_process_builder.dart->package:build/src/builder/post_process_builder.dart->package:build/src/builder/builder.dart->package:build/src/builder/build_step.dart->package:build/src/asset/reader.dart->package:glob/glob.dart->package:glob/src/list_tree.dart->package:glob/src/io.dart->package:glob/src/io_export.dart->dart:io

Health suggestions

Fix lib/src/singleton_class_generator.dart. (-0.50 points)

Analysis of lib/src/singleton_class_generator.dart reported 1 hint:

line 2 col 8: Don't import implementation files from another package.

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (analyzer).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and singleton_class_generator.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
analyzer ^0.38.5 0.38.5 0.39.11
build ^1.2.0 1.3.0
singleton_class_annotation ^0.1.0 0.1.0+1
source_gen ^0.9.4+5 0.9.4+6 0.9.5
Transitive dependencies
args 1.6.0
async 2.4.1
charcode 1.1.3
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.5
csslib 0.16.1
dart_style 1.3.3 1.3.6
flutter 0.0.0
front_end 0.1.27 0.1.29
glob 1.2.0
html 0.14.0+3
js 0.6.2
kernel 0.3.27 0.3.29
logging 0.11.4
meta 1.1.8 1.2.0
node_interop 1.1.1
node_io 1.1.1
package_config 1.9.3
path 1.7.0
pedantic 1.9.0 1.9.1
pub_semver 1.4.4
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8
watcher 0.9.7+15
yaml 2.2.1
Dev dependencies
build_runner any
build_test any
flutter_test any