simply_injector 0.1.4

Dart native js
Flutter Android iOS web

An easy-to-use Dependency Injection (DI) library for Dart, inspired and based on Simple Injector library. It is easily integrated with Flutter.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  simply_injector: ^0.1.4

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:simply_injector/simply_injector.dart';
1
likes
90
pub points
13%
popularity

An easy-to-use Dependency Injection (DI) library for Dart, inspired and based on Simple Injector library. It is easily integrated with Flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

lamkrodrigues@gmail.com
flutuate.io@gmail.com

License

BSD (LICENSE)

Dependencies

meta

More

Packages that depend on simply_injector