simpleappbar 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 46

simpleappbar #

Simple app bar which is aware of network status.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

simple_appbar #

[0.0.1] - June, 7, 2020 #

  • Build widget under appbar as soon as network is disconnected

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:simpleappbar/simpleappbar.dart';

void main() {
  runApp(MyApp());
}

class MyApp extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
        visualDensity: VisualDensity.adaptivePlatformDensity,
      ),
      home: MyHomePage(),
    );
  }
}

class MyHomePage extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: SimpleAppBar(
        context: context,
        title: Text('Simple appbar'),
      ),
      body: ListView.builder(
        itemCount: 30,
        itemBuilder: (BuildContext context, int index) {
          return Container(
            height: 50.0,
            color: Colors.black,
            margin: EdgeInsets.all(16.0),
            child: Center(
              child: Text(
                "${index + 1}",
                style: TextStyle(color: Colors.white),
              ),
            ),
          );
        },
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  simpleappbar: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:simpleappbar/simpleappbar.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
78
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform Linux

Because:

  • package:simpleappbar/simpleappbar.dart that imports:
  • package:simpleappbar/src/simple_appbar.dart that imports:
  • package:simpleappbar/src/connectivity_status.dart that imports:
  • package:connectivity/connectivity.dart that declares support for platforms: Android, iOS, macOS, Web

Package does not support Flutter platform Windows

Because:

  • package:simpleappbar/simpleappbar.dart that imports:
  • package:simpleappbar/src/simple_appbar.dart that imports:
  • package:simpleappbar/src/connectivity_status.dart that imports:
  • package:connectivity/connectivity.dart that declares support for platforms: Android, iOS, macOS, Web

Package not compatible with SDK dart

Because:

  • simpleappbar that is a package requiring null.

Health suggestions

Format lib/src/connectivity_status.dart.

Run flutter format to format lib/src/connectivity_status.dart.

Format lib/src/simple_appbar.dart.

Run flutter format to format lib/src/simple_appbar.dart.

Maintenance suggestions

The package description is too short. (-12 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
connectivity ^0.4.8+6 0.4.9
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
connectivity_for_web 0.3.0
connectivity_macos 0.1.0+3
connectivity_platform_interface 1.0.6
flutter_web_plugins 0.0.0
js 0.6.2
meta 1.1.8 1.2.2
plugin_platform_interface 1.0.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test