simple_sass_transformer 0.0.2+1

  • Installing
  • Versions
  • 0

Dart Sass for Pub #

This transfomer simply compiles .scss and .sass files to .css files.

Since it depends on dart-sass, there is no need to have Sass installed.

Usage #

Add the following lines to your pubspec.yaml:

  simple_sass_transformer: 0.0.2
  - simple_sass_transformer

Assume you have /path/to/file.scss or /path/to/file.sass, add these lines to your index.html:

  <link rel="stylesheet" href="/path/to/file.css">

If relative paths are not so pretty for you, you can instead use package: just like in your .dart files.

@import 'package:your_package_name/styles';

Changelog #

0.0.2 #

  • Add support for package_resolver

0.0.1 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  simple_sass_transformer: ^0.0.2+1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:simple_sass_transformer/transformer.dart';
Version Uploaded Documentation Archive
0.0.2+1 Mar 12, 2017 Go to the documentation of simple_sass_transformer 0.0.2+1 Download simple_sass_transformer 0.0.2+1 archive
0.0.2 Mar 12, 2017 Go to the documentation of simple_sass_transformer 0.0.2 Download simple_sass_transformer 0.0.2 archive
0.0.1+1 Jan 7, 2017 Go to the documentation of simple_sass_transformer 0.0.1+1 Download simple_sass_transformer 0.0.1+1 archive
0.0.1 Jan 7, 2017 Go to the documentation of simple_sass_transformer 0.0.1 Download simple_sass_transformer 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0