simple_rate_my_app 1.0.0

  • Readme
  • Changelog
  • Installing
  • new55

Simple RateMyApp #

Getting Started #

SimpleRateMyApp.init(
    // Define your rule (or just use the default rule)
    ruleToShow: () {
        return SimpleRateMyApp.daysElapsed == 8;
    }
    // Define your callback when the rule is true
    onShowAndroid: (){
        // Your Custom Rate Dialog
    },
    onShowIOS: () {
        // Your Custom Rate Dialog
        // or 
        // default: SimpleRateMyApp.openIosRateDialog();
    },
);

All Functions #

SimpleRateMyApp.init();
SimpleRateMyApp.show(); // check rule and active callback
SimpleRateMyApp.reset(); 
SimpleRateMyApp.dontShowMore();
SimpleRateMyApp.daysElapsed // int
SimpleRateMyApp.launchesElapsed // int
SimpleRateMyApp.openStore();  // Navigates to Store Listing in Google Play/App Store.
SimpleRateMyApp.openIosRateDialog(); // Open Native Ios Rate Dialog

[1.0.0] - 06/28/2020 #

  • Simple way to get user rating Initial Release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  simple_rate_my_app: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:simple_rate_my_app/simple_rate_my_app.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
22
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
55
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform Linux

Because:

  • package:simple_rate_my_app/simple_rate_my_app.dart that imports:
  • package:app_review/app_review.dart that declares support for platforms: Android, iOS

Package does not support Flutter platform Web

Because:

  • package:simple_rate_my_app/simple_rate_my_app.dart that imports:
  • package:app_review/app_review.dart that declares support for platforms: Android, iOS

Package does not support Flutter platform Windows

Because:

  • package:simple_rate_my_app/simple_rate_my_app.dart that imports:
  • package:app_review/app_review.dart that declares support for platforms: Android, iOS

Package does not support Flutter platform macOS

Because:

  • package:simple_rate_my_app/simple_rate_my_app.dart that imports:
  • package:app_review/app_review.dart that declares support for platforms: Android, iOS

Package not compatible with SDK dart

Because:

  • simple_rate_my_app that is a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

13 out of 13 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and simple_rate_my_app.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
app_review ^1.1.2 1.1.2
flutter 0.0.0
hive ^1.4.1+1 1.4.1+1
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.5
flutter_web_plugins 0.0.0
http 0.12.1
http_parser 3.1.4
meta 1.1.8 1.2.2
package_info 0.4.1
path 1.7.0
pedantic 1.9.0 1.9.2
platform_detect 1.4.0
plugin_platform_interface 1.0.2
pub_semver 1.4.4
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
url_launcher 5.5.0
url_launcher_linux 0.0.1+1
url_launcher_macos 0.0.1+7
url_launcher_platform_interface 1.0.7
url_launcher_web 0.1.2
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test
lint ^1.2.0