simple_design 0.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 65

simple_design #

A simple design library for Flutter.

This package includes:

  • Premade themes, dark and light brightness
  • Several custom Simple Design widgets, serving the original design idea.

Link to the example images: https://imgur.com/a/duatQYT

For general design advice I used the Material Design Specifications from material.io.

SDAppBar and SDSliverAppBar #

These two widgets are meant to be used instead of the regular AppBar/SliverAppBar. They use certain styling that otherwise would have to be applied to every AppBar in your app.

They are customizable with title, leading, actions, bottom, automaticallyImplyLeading and flexibeSpace. The other values are not customizable to not negatively impact the appearance of your app.

SDAppBar and SDSliverAppBar

SDDialog with SDDismissButton and SDActionButton #

This is a custom dialog and should be used in the showDialog() method instead of AlertDialog or SimpleDialog. It can be given values for title, content, a SDDismissButton for a dismiss button, a SDActionButton for an action button and a bool barrierDismissable, which is not yet working.

The SDDismissButton and SDActionButton should be self-explaining.

SDDialog with SDDismissButton and SDActionButton

SDDivider and SDSectionHeader #

Designed for the use in Colums and Lists, the SDDivider provides a vertical padding of 36.0 pixels, which is recommended, but can be customized with the height property.

The SDSectionHeader is to be used below a SDDivider to announce the title of a new section, as it can be seen in the example application.

SDSectionHeader

SDCard #

The SDCard widget is a highly customizable card, with options for mediaContent, content, title, subtitle, actions and backgroundColor. It has a slight shadow underneath and is best used in Colums and Lists.

SDCard

[1.0.0] - 16.12.2018.

  • Initial Release with Light and Dark Themes and several widgets.

example/README.md

example #

The example for the Flutter Simple Design package.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  simple_design: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:simple_design/simple_design.dart';
  
Version Uploaded Documentation Archive
1.0.3 Dec 16, 2018 Go to the documentation of simple_design 1.0.3 Download simple_design 1.0.3 archive
1.0.2 Dec 16, 2018 Go to the documentation of simple_design 1.0.2 Download simple_design 1.0.2 archive
1.0.1 Dec 16, 2018 Go to the documentation of simple_design 1.0.1 Download simple_design 1.0.1 archive
0.0.1 Dec 16, 2018 Go to the documentation of simple_design 0.0.1 Download simple_design 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
43
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
65
Learn more about scoring.

We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.0
  • pana: 0.12.15
  • Flutter: 1.5.8

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test