simple_coverflow 0.0.8

  • Readme
  • Changelog
  • Example
  • Installing
  • 85

Pub

Simple Coverflow for Flutter #

A very basic cover flow implementation to swipe between widgets in Flutter.

It should look something like this:

gif of project

Pull requests certainly welcome.

Installation #

In your pubspec.yaml root add:

dependencies:
  simple_coverflow: LATEST_VERSION_NUMBER

then,

import 'package:simple_coverflow/simple_coverflow.dart';

[0.0.8] - 3/12/19

  • Updated version constraints to be much more permissive of what Flutter and SDK versions are accepted.

[0.0.7] - 4/19/18

  • Added ValueNotifier so that other interested classes can keep track of what item is displayed on the CoverFlow.

[0.0.6] - 4/19/18

  • Added made the builder parameter a named argument [itemBuilder] in keeping with flutter conventions.

[0.0.5] - 4/18/18

  • Added [itemCount] field so that users can have a non-infinitely scrolling cover flow. Also adjusted the default viewport value.

[0.0.4] - 4/17/18

  • Bumped versioning constraints to support much later versions of Flutter.

[0.0.3] - 4/12/18

  • Changed typedef of OnDismissedCallback to return the number of the item called rather than the item itself.

[0.0.1] - 4/12/18

  • Initial implementation of simple coverflow.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:simple_coverflow/simple_coverflow.dart';

void main() => runApp(new MyApp());

class MyApp extends StatelessWidget {
  static List<Container> data = [
    new Container(color: Colors.orange),
    new Container(color: Colors.blue),
    new Container(color: Colors.amber),
    new Container(color: Colors.deepPurple),
    new Container(color: Colors.green),
    new Container(color: Colors.red),
    new Container(color: Colors.yellow),
    new Container(color: Colors.greenAccent),
    new Container(color: Colors.black)
  ];

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Coverflow Demo',
      theme: new ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: new Scaffold(
          appBar: new AppBar(
            title: new Text('Coverflow Demo'),
          ),
          body: new CoverFlow(itemBuilder: widgetBuilder,
              dismissedCallback: disposeDismissed,
              currentItemChangedCallback: (int index) {print(index);})
      ),
    );
  }

  Widget widgetBuilder(BuildContext context, int index) {
    if (data.length == 0) {
      return new Container();
    } else {
      return data[index % data.length];
    }
  }

  disposeDismissed(int item, DismissDirection direction) {
    data.removeAt(item % data.length);
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  simple_coverflow: ^0.0.8

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:simple_coverflow/simple_coverflow.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
76
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
85
Learn more about scoring.

We analyzed this package on Nov 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/simple_coverflow.dart. (-1.49 points)

Analysis of lib/simple_coverflow.dart reported 3 hints:

line 56 col 22: Don't explicitly initialize variables to null.

line 56 col 44: Don't explicitly initialize variables to null.

line 56 col 67: Don't explicitly initialize variables to null.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test