shrine_images 1.1.1

  • Installing
  • Versions
  • 89

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  shrine_images: ^1.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
1.1.2 May 8, 2019 Go to the documentation of shrine_images 1.1.2 Download shrine_images 1.1.2 archive
1.1.1 Oct 31, 2018 Go to the documentation of shrine_images 1.1.1 Download shrine_images 1.1.1 archive
1.1.0 Oct 11, 2018 Go to the documentation of shrine_images 1.1.0 Download shrine_images 1.1.0 archive
1.0.0 Apr 25, 2018 Go to the documentation of shrine_images 1.0.0 Download shrine_images 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
98
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
89
Learn more about scoring.

We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.0
  • pana: 0.12.15
  • Flutter: 1.5.8

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Provide a file named README.md. (-30 points)

The README.md file should inform others about your project, what it does, and how they can use it. See the example generated by stagehand.

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test