shrine_images 1.1.0

  • Installing
  • Versions
  • 49

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  shrine_images: ^1.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
1.1.2 May 8, 2019 Go to the documentation of shrine_images 1.1.2 Download shrine_images 1.1.2 archive
1.1.1 Oct 31, 2018 Go to the documentation of shrine_images 1.1.1 Download shrine_images 1.1.1 archive
1.1.0 Oct 11, 2018 Go to the documentation of shrine_images 1.1.0 Download shrine_images 1.1.0 archive
1.0.0 Apr 25, 2018 Go to the documentation of shrine_images 1.0.0 Download shrine_images 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
98
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
49
Learn more about scoring.

We analyzed this package on May 23, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.1
  • pana: 0.12.16
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter packages pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.3.0-dev.0.5.flutter-a1668566e5.
 
 Because shrine_images requires SDK version >=1.19.0 <2.1.0, version solving failed.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Support the latest stable Dart SDK in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow the latest stable Dart SDK release.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Provide a file named README.md. (-30 points)

The README.md file should inform others about your project, what it does, and how they can use it. See the example generated by stagehand.

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.1.0