show 0.5.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 10

Show(Case) #

ShowCase your flutter app.


Getting Started #

To install show globally use: flutter pub global activate show

You will also have to add show to your dependencies:

  show: <version>

Setup project #

The init command will create a showcase/ directory in your project root.

An entry showcase/showcase.dart will be created once. This file can be modified and will not be recreated as long as it exists.

show init

Creating show cases #

The showcases need to be created within the newly created showcase/ folder.

Whenever you've created new files containing showcases you will need to run show init again which will recreate showcase/showcase.g.dart. This is in order to update the files to be imported by the application.

If you modify existing showcases they will be hot reloaded just like any other widget.

Example show case:


import 'package:flutter/material.dart';
import 'package:show/show.dart';

void showCase(Show controls) {
    ..add('Card', () => {
            onTap: action('Hello ShowCase'),
            child: Card(
      Card(color: Colors.yellow),
    ..add('CircularProgressIndicator', (_) => {
      const CircularProgressIndicator(),
      const CircularProgressIndicator(
            strokeWidth: 10,
      const CircularProgressIndicator(
            value: 0.4,

Build Web Version #

To build a web version use:

show build

The build will be written to build/showcase/web.

Development #

To activate the show package globally from within the develop directory use:

flutter pub global activate --source path <repository_path>

0.5.2 #

  • Make area dividers draggable.

0.5.1 #

  • Update readme to use new api.

0.5.0 #

  • Breaking, change signature of showcase function

0.4.1 #

  • expose build context to showcase functions

0.4.0 #

  • add web builder
  • make main section scrollable

0.3.2 #

  • inject theme
  • change default layout

0.3.1 #

  • update menu styling

0.3.0 #

  • add tree menu
  • add logo
  • make title optional

0.2.1 #

  • update readme

0.2.0 #

  • hot reload show cases
  • fix font sizes

0.1.0 #

  • fix not generating showcase/showcase.dart
  • be less verbose

0.0.7 #

  • generate showcase/showcase.dart
  • improve showcase/showcase.g.dart

0.0.6 #

  • rename entry file to show.dart
  • export master detail container

0.0.5 #

  • only parse files in showcase/ dir

0.0.4 #

  • typos and set target dir to showcase/

0.0.3 #

  • read version from generated file

0.0.2 #

  • fix meta dependency conflict

0.0.1 #

  • initial release


example #


flutter pub run ../bin/show.dart build

Use this package as an executable

1. Install it

You can install the package from the command line:

$ pub global activate show

2. Use it

The package has the following executables:

$ show

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  show: ^0.5.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:show/show.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 20, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter pub upgrade failed with the following output:

ERR: Because every version of flutter_tools from sdk depends on analyzer 0.38.5 and show depends on analyzer >=0.35.0 <0.38.0, flutter_tools from sdk is forbidden.
 So, because show depends on flutter_tools any from sdk, version solving failed.

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0