shelter 0.0.2

  • Readme
  • Changelog
  • Installing
  • 37

shelter #

Skelter labs Flutter library commonly used

Getting Started #

TBD

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

[0.0.2] #

  • Add common, dialog, firebase_auth utils
  • Add loading showables
  • Add widgets

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  shelter: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:shelter/shelter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
96
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
42
Overall:
Weighted score of the above. [more]
37
Learn more about scoring.

We analyzed this package on Jul 12, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:shelter/shelter.dart that imports:
  • package:shelter/utils.dart that imports:
  • package:shelter/src/utils/firebase_auth_util.dart that imports:
  • package:firebase_auth/firebase_auth.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:shelter/shelter.dart that imports:
  • package:shelter/utils.dart that imports:
  • package:shelter/src/utils/firebase_auth_util.dart that imports:
  • package:firebase_auth/firebase_auth.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:shelter/shelter.dart that imports:
  • package:shelter/utils.dart that imports:
  • package:shelter/src/utils/firebase_auth_util.dart that imports:
  • package:firebase_auth/firebase_auth.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:shelter/shelter.dart that imports:
  • package:shelter/utils.dart that imports:
  • package:shelter/src/utils/firebase_auth_util.dart that imports:
  • package:firebase_auth/firebase_auth.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • shelter that is a package requiring null.

Health suggestions

Fix lib/src/utils/dialog_util.dart. (-2.48 points)

Analysis of lib/src/utils/dialog_util.dart reported 5 hints:

line 30 col 65: 'title' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is headline6. This feature was deprecated after v1.13.8..

line 100 col 69: 'body1' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is bodyText2. This feature was deprecated after v1.13.8..

line 174 col 56: 'body1' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is bodyText2. This feature was deprecated after v1.13.8..

line 215 col 48: 'subhead' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is subtitle1. This feature was deprecated after v1.13.8..

line 230 col 42: 'headline' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is headline5. This feature was deprecated after v1.13.8..

Fix lib/src/widgets/flat_list_box.dart. (-1 points)

Analysis of lib/src/widgets/flat_list_box.dart reported 2 hints:

line 37 col 48: 'body1' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is bodyText2. This feature was deprecated after v1.13.8..

line 129 col 44: 'subhead' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is subtitle1. This feature was deprecated after v1.13.8..

Fix lib/src/widgets/shelter_text_field.dart. (-1 points)

Analysis of lib/src/widgets/shelter_text_field.dart reported 2 hints:

line 147 col 34: 'subhead' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is subtitle1. This feature was deprecated after v1.13.8..

line 184 col 40: 'subtitle' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is subtitle2. This feature was deprecated after v1.13.8..

Fix additional 4 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/mixins/loading_showable.dart (Run flutter format to format lib/src/mixins/loading_showable.dart.)
  • lib/src/rendering/circle_painter.dart (Run flutter format to format lib/src/rendering/circle_painter.dart.)
  • lib/src/utils/common_util.dart (Run flutter format to format lib/src/utils/common_util.dart.)
  • lib/src/utils/firebase_auth_util.dart (Run flutter format to format lib/src/utils/firebase_auth_util.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (firebase_auth, flutter_slidable).

The package description is too short. (-18 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and shelter.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
firebase_auth ^0.11.1 0.11.1+12 0.16.1
flutter 0.0.0
flutter_slidable ^0.4.9 0.4.9 0.5.4
pedantic ^1.8.0+1 1.9.0 1.9.2
quiver >=2.0.0 <3.0.0 2.1.3
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
firebase 7.3.0
firebase_core 0.4.5
firebase_core_platform_interface 1.0.4
firebase_core_web 0.1.1+2
flutter_web_plugins 0.0.0
http 0.12.1
http_parser 3.1.4
js 0.6.2
matcher 0.12.8
meta 1.1.8 1.2.2
path 1.7.0
plugin_platform_interface 1.0.2
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test