shared_versions 2.0.0
shared_versions: ^2.0.0 copied to clipboard

shared_versions is a CLI tool that allow share the versions for multiple packages in Flutter.

Use this package as an executable

Install it

You can install the package from the command line:

dart pub global activate shared_versions

Use it

The package has the following executables:

$ shared_versions

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add shared_versions

With Flutter:

 $ flutter pub add shared_versions

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  shared_versions: ^2.0.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:shared_versions/shared_versions.dart';
5
likes
120
pub points
31%
popularity

shared_versions is a CLI tool that allow share the versions for multiple packages in Flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

ansicolor, args, meta, yaml

More

Packages that depend on shared_versions