shared_prefs_resource 0.0.2+1

  • Readme
  • Changelog
  • Installing
  • 54

shared_prefs_resource #

An AsyncResource interface for Flutter shared preferences storage.

Deprecated #

Please use async_resource_flutter instead.

Examples #


final stringRes = StringPrefsResource('string');
final boolRes = BoolPrefsResource('bool');
final intRes = IntPrefsResource('int');
final doubleRes = DoublePrefsResource('double');
final stringListRes = StringListPrefsResource('list');

[0.0.2+1] - October 3, 2018

[0.0.2] - August 25, 2018

  • Fix docs.

[0.0.1] - August 25, 2018

  • First release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  shared_prefs_resource: ^0.0.2+1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:shared_prefs_resource/shared_prefs_resource.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Oct 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (shared_preferences).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and shared_prefs_resource.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Package is getting outdated. (-4.66 points)

The package was last published 54 weeks ago.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <3.0.0
async_resource ^0.1.2 0.1.4
flutter 0.0.0
shared_preferences ^0.4.2 0.4.3 0.5.3+5
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.11 1.14.12
http 0.12.0+2
http_parser 3.1.3
js 0.6.1+1
meta 1.1.7
path 1.6.4
pedantic 1.8.0+1
rxdart 0.18.1 0.22.4
service_worker 0.2.3
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies