An AsyncResource interface for Flutter shared preferences storage.
final stringRes = StringPrefsResource('string'); final boolRes = BoolPrefsResource('bool'); final intRes = IntPrefsResource('int'); final doubleRes = DoublePrefsResource('double'); final stringListRes = StringListPrefsResource('list');
[0.0.2+1] - October 3, 2018
- Deprecated. Please use
[0.0.2] - August 25, 2018
- Fix docs.
[0.0.1] - August 25, 2018
- First release.
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: shared_prefs_resource: ^0.0.2+1
2. Install it
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Oct 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.5.1
- pana: 0.12.21
- Flutter: 1.9.1+hotfix.4
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
Maintenance issues and suggestions
Support latest dependencies. (-10 points)
The version constraint in
pubspec.yaml does not support the latest published versions for 1 dependency (
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
shared_prefs_resource.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
Package is pre-v0.1 release. (-10 points)
While nothing is inherently wrong with versions of
0.0.*, it might mean that the author is still experimenting with the general direction of the API.
Package is getting outdated. (-4.66 points)
The package was last published 54 weeks ago.
|Dart SDK||>=1.19.0 <3.0.0|